Delay in usability for newly provisioned texting channels caused by upstream provider issues
Incident Report for Prompt.io
Resolved
We are finally(!) seeing somewhat normal times to provision and activate new 10DLC numbers. It only took the carriers and our upstream providers 5 days to get it sorted. Thank you for your patience and understanding.
Posted Jun 10, 2022 - 16:03 PDT
Update
There are still some delays in new number provisioning with our upstream carrier partners. We expect this to finally get this matter resolved today. Newly provisioned numbers are being cleared from the carrier backlog regularly, but there are still some outstanding issues here that we're tracking closely.
Posted Jun 10, 2022 - 08:12 PDT
Update
There are still some lingering issues with new some phone number purchases for SMS getting connectivity through Campaign Registry and upstream providers. These seem to be clearing slowly. We expect full resolution soon. Existing channels are not experiencing any issues.
Posted Jun 09, 2022 - 07:28 PDT
Update
Delays for provisioning new numbers are clearing up, but there are still some issues when provisioning new SMS and MMS enabled 10DLC numbers in the platform due to upstream carriers. We continue to monitor.
Posted Jun 08, 2022 - 14:55 PDT
Update
Issues with newly provisioned 10DLC SMS channels are still occurring with our upstream providers. There are no issues sending or receiving texts from previously provisioned phone numbers prior to Monday June 6. We will update when we hear progress from the carriers on this issue.
Posted Jun 08, 2022 - 08:49 PDT
Monitoring
Our upstream SMS and MMS provider is experiencing issues when provisioning new text phone numbers. Newly provisioned channels in Prompt may not become usable today as they work through this issue. We are in contact with the upstream providers and are closely monitoring the situation. The upstream provider is undergoing maintenance on this issue with expected delays in provisioning continuing through Tuesday, June 7 11:45pm. We are sorry for the inconvenience.

Previously provisioned channels are all working as expected. Only channels provisioned today are experiencing these issues.
Posted Jun 07, 2022 - 10:12 PDT
This incident affected: Prompt.io (Production) - API and Prompt.io (Production) - Agent Tools.