10DLC number assignment delayed
Incident Report for Prompt.io
Resolved
The backlog of provisioning issues are clearing. However, the carriers and upstream partners have informed us that there are several "manual" steps that are slowing down the provisioning process. We are closely monitoring the situation and working to expedite provisioning of new phone numbers where possible. It is unlikely, but possible, that new organizations provisioning for the first time may take a week or more to become fully operational on registered 10DLC.
Posted Jun 15, 2022 - 17:57 PDT
Update
We are seeing some phone number assignments process today, albeit slowly. Some assignments have been processing in 30 minutes. There are still latent issues with assignments that were requested several days ago still "stuck" in Pending status at the carriers. We are in constant communication with our upstream partners on this issue. Thank you for your patience.
Posted Jun 15, 2022 - 07:32 PDT
Update
Number provisioning is slow with our upstream providers. We continue to work with with the carriers to ensure that numbers can be provisioned in a normal time frame.
Posted Jun 14, 2022 - 07:45 PDT
Monitoring
Our upstream messaging providers are experiencing delayed assignment of 10DLC numbers to messaging campaigns. The providers are working to resolve the issue. This is the same issue that was occurring last week. For existing 10DLC phone numbers, no impact is expected.
Posted Jun 13, 2022 - 13:36 PDT
This incident affected: Prompt.io (Production) - API and Prompt.io (Production) - Agent Tools.